技术CTO-关注编程入门知识,提供编程入门教程

您的位置: 首页 > 移动开发 > ios > 正文

关于xcode6安装ios7模拟器的问题

来源: 技术CTO 阅读:

我在 xcode 6  安装了ios7的模拟器(是复制xcode 5的那个的),在选择项目deployment target 为ios 7的时候,模拟器没有自动切换成ios7的,依然是用ios8的来运行,,有小伙伴遇到过这个问题吗。。。 我在xcode5 完全没有问题。求解

感谢邀请,我个人没有做过像你这样直接从Xcode5那里复制iOs7模拟器的做法,不过我在Beta 2时从Xcode->Preferences->Downloads下载的iOs7模拟器没有出现你这样的问题,建议你也按这样的方式下载。
直接复制模拟器。。。没试过这样做,不是可以选择模拟器的么?
把 Build Settings里的Base SDK 也切换到7
引用 1 楼 sinom 的回复:
感谢邀请,我个人没有做过像你这样直接从Xcode5那里复制iOs7模拟器的做法,不过我在Beta 2时从Xcode->Preferences->Downloads下载的iOs7模拟器没有出现你这样的问题,建议你也按这样的方式下载。
 这样在线下载巨慢,翻墙了  都很慢,而且 xcode 6 在 downloads 那里已经没有 ios 6的模拟器了
引用 2 楼 c772950145 的回复:
直接复制模拟器。。。没试过这样做,不是可以选择模拟器的么?
 是的 不能够选择模拟器  修改项目的deployment target 耶不可以
引用 3 楼 c772950145 的回复:
 你的ios 7模拟器是在线安装的吗  
引用 7 楼 jackyuan918 的回复:
Quote: 引用 2 楼 c772950145 的回复:

直接复制模拟器。。。没试过这样做,不是可以选择模拟器的么?
 是的 不能够选择模拟器  修改项目的deployment target 耶不可以

可以的,复制过去就 能用了。 我是把sdk和模拟器都复制过去了
BaseSDK=8.0,Deployment Target=7.1,目标可以选7.1和8.0
BaseSDK=8.0,Deployment Target=8.0,目标可以选8.0
BaseSDK=7.1,Deployment Target=7.1,目标可以选7.1和8.0
BaseSDK=7.1,Deployment Target=8.0,目标可以选8.0
引用 8 楼 jackyuan918 的回复:
Quote: 引用 3 楼 c772950145 的回复:

 你的ios 7模拟器是在线安装的吗  
 是不是我没有下载那个ios 8 library , 这个貌似要注册那个开发者账号才能下载?

^_^ 如果您热爱技术、热爱编程,想与更多的朋友一起交流学习,欢迎加入本站官方QQ群:345733473 ^_^