技术CTO-关注编程入门知识,提供编程入门教程

您的位置: 首页 > 前端开发 > javascript > 正文

大家有没有发现360浏览器版本6.x后很多正常用到的js不能用了,请问如何解决?

来源: 技术CTO 阅读:

之前用到的很都很常见的js在360 6.x版本下都不能用了,不知道是为什么?
比如以前一直用列表记录页的全选功能,代码如下:

xxx.html

<SCRIPT LANGUAGE="JavaScript" src="/js/eu_js.js"></SCRIPT>

<A HREF="#" title="全选" onclick="location.href='javascript:selectall();';return false;">选择</A>

------------------------
eu_js.js

function selectall(a) {
   var a = document.getElementsByTagName("input");
   for (var i=0; i<a.length; i++)
      if (a[i].type == "checkbox" && a[i].name=="id") a[i].checked =!a[i].checked;
}
-------------------
这些代码在IE下,和360 6.x一下的版本都能用,到 360 6.x版本后就失效了, 而且不止这一个,好多都失效了,我从百度搜索没找到多少人提出这个问题,难道就我自己有这个问题吗? 其他朋友没遇到过吗?
有遇到的请问大家是怎么解决的啊?
非常感谢

因为大家都不用360 所以你找不到答案
换浏览器吧
高版本的360默认极速模式是webkit核心的,有调试工具,自己看是不是报错了还是什么

^_^ 如果您热爱技术、热爱编程,想与更多的朋友一起交流学习,欢迎加入本站官方QQ群:345733473 ^_^